January 19, 2021

Apple iOS 15 won’t Support iPhone 6S and Old SE rumors suggest

Apple 2020 cover

Apple 2020 cover

Apple iOS 15 won’t Support iPhone 6S and Old SE rumors suggest. As per some early news, the iOS 15 will not support iPhone 6S, 6S Plus, and the old SE model. These models were released in 2015 and 2016 which will be around 5-6 years old. Apple provides updates to their devices for around 4-5 years, which is a great Software support Lifecycle by far. This is the advantage when Hardware and Software come under a single umbrella. Google lacks this as apart from Pixel all Manufacturers do as they like and sometimes a 1000$ Flagship may also miss critical or long-term software support.

The news picked up from Macrumors and it had taken the same from an Israeli site The Verifier. The site isn’t that accurate, but they were pretty accurate with the iOS 14 updates. 

Below is the list of Apple iOS 15 compatible devices if the rumors are accurate:

Apple iPhones:
2021 iPhone series, 12 Pro Max, 12 Pro, 12 mini, 12, 11 and 11 Pro, 11 Pro Max, XS, XS Max, XR, X, 8, 8 Plus, iPhone 7, iPhone 7 Plus, iPhone SE (2020),

iPod touch (7th generation)

There is no word from The Verifier about the iPad models receiving the iOS 15 update. How important are Software updates to you? Whether major or minor. Do let us know and Engage with us.

Follow us on Facebook & Twitter. Stay Connected.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.